TrustedQSL 2.5.3

Do you use Logbook of The World, LoTW? If so, TrustedQSL, TQSL, version 2.5.3 has been released.

Are you still on version 2.5.2? Updated to 2.5.3 now as the conclution is “don’t use 2.5.2”.